Announcement

Collapse
No announcement yet.

Ctrl+Shift+Right Arrow malfunction

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ctrl+Shift+Right Arrow malfunction

    New Aorus, fresh out of the box, no macros set, and I've got this glitch happening that I need fixed:

    Highlighting previous text, word by word, works using the normal Ctrl+Shift+Left Arrow. However, highllighting following text, word by word, using Ctrl+Shift+Right Arrow highlights nothing and instead skips me to the end of the document. It's doing the same thing in every program I've tried it in - Word, Notepad, UltraEdit, etc. I've never encountered such a glitch on any computer I've used before, and it's a real problem for me because I write and edit a lot of text and need to be able to use the feature.

    To note, Ctrl+Left Arrow and Ctrl+Right Arrow both work just fine to hop forwards and backwards word by word, no glitch. But add in the Shift when the right arrow is pressed, and glitch.

  • #2
    Hi,

    Have you updated the Keyboard firmware suggested in the announcement section? or on the official AORUS website?

    Thanks!

    Comment


    • #3
      I went to where you mentioned and downloaded AorusX_V1.1.2.exe and ran it (clicked "Connect" and "Program"). Now neither Ctrl+Shift+Left Arrow nor Ctrl+Shift+Right Arrow work *at all*; it's as if I'm not pressing anything. This is less good than before.

      Comment


      • #4
        Hi,

        can you please send me a screenshot of your update center (where it has all the update/firmware info and update functions).
        Please update everything to the latest version.
        What about your windows update version?
        There are a lot of aspects to consider. I would need to transfer that to the testing team.
        Because it seems like it is not a hardware problem, but in case if all fails, you may need to send in your unit for an RMA or if your unit is new enough, you can ask your purchase point if they offer an exchange.

        Thanks!

        Comment


        • #5
          Hello, I just discovered I have the very same problem. If you use https://www.microsoft.com/appliedsci...stingDemo.mspx to test which keys are pressed and the effects of ghosting it turns out that if you press CTRL-SHIFT-RIGHT ARROW, the keyboard registers as if you pressed also END.

          Using the same test turns out that if you press WSD together keyboard records also E as pressed, and it you press WAS together keyboard records Q as pressed too...

          Antighosting????????????

          Comment


          • #6
            Update: just updated firmware to 1.1.2 and yes, as the OP was saying now CTRL-SHIFT-ARROWS no longer works. Check the test link above: this firmware solved ghosting with eliminating key combinations! if you press WSD together W is not registered WAS is the same. CTRL-SHIFT-ARROW the same... lousy fix if you ask me.

            Back to my word file now where I have to select text letter by letter now thanks to this. And AORUS-MKT please don't say we have to RMA our units, it is pretty clear that the X5V6 has keyboard issues so please let the tech team do a proper firmware update so that we can have the anti-ghosting we have paid for but full keyboard functionality (which ok, was not in the specs, but one sort of assumes it comes with the laptop.)

            Comment


            • AORUS-MKT
              AORUS-MKT commented
              Editing a comment
              I must say that you are right sir.
              After reading your comments I went straight to the testing team.
              They will take a look at a fix ASAP!

              Cheers.

          • #7
            Also updated to 1.1.2 recently and I'm actually having the same problem on my X5 v6, but only if I use the left cntrl key in combination with a shift key. But the right one works as it should. I suspect this has something to do with the other problem I am having... that shift+Z doesn't work properly either. I keep on discovering new key combinations that are causing problems.

            And the fn key combinations don't work at all.

            Pretty frustrating.

            Comment


            • #8
              The AORUS team is working on a new firmware to resolve such an issue. Please stay tuned.

              Cheers!

              Comment


              • #9
                Thanks that's very good to know!

                Comment


                • #10
                  I was frustrated by the response so did not reply again, hoping instead my seller could figure out how to solve the problem for me. So, xexets, I thank you very much for taking initative and looking at this! xexets and llehsadam, sorry it's also happening to you, but I'm glad to know I'm not nuts.

                  AORUS-MKT, thank you for now taking care of this problem quickly. I would appreciate an update note when it has been solved.

                  I forgot to mention I am using an X7 v6-PC3D (not an X5).

                  Comment


                  • #11
                    Hey Eris, just a quick tip I discovered 3 seconds ago. In my x5 v6 CTRL-SHIFT-ARROW works fine if you use LEFT SHIFT + RIGHT CTRL +any arrow. left shift and left ctrl blocks the arrows, right shift + right ctrl + arrow ignores ctrl, and lo and behold RIGHT CTRL + LEFT SHIFT works, but only with RIGHT ARROW. Anyways, I hope this helps you too editing your word files until the tech team fixes this properly.

                    I suggest fiddling with the link above, as it give you a clear idea of the key combinations that work, those that don't and those that create quirky additional presses on your own keyboard!

                    Comment


                    • #12
                      Confirmed that LEFT CTRL + SHIFT + Arrow not working with v1.1.2 firmware.

                      I'm looking forward for the fix. This is damaging my productivity.

                      Comment


                      • #13
                        Just wanted to add that I'm experiencing the same issue on my X5 v6. LSHIFT+LCTRL+arrow doesn't work at all, RSHIFT+RCTRL+arrow works for all but the left arrow, RSHIFT+LCTRL+arrow works for all but the left arrow, and LSHIFT+RCTRL+arrow works for all arrow keys.

                        llehsadam, using SHIFT+z to type an uppercase Z works fine here. No issues that I've discovered with the Fn key either.

                        An additional key combination I've found that doesn't work is LSHIFT+LCTRL+n in Chrome to open a new incognito window. It works fine with every other combination of SHIFT+CTRL, just not the two left keys together. However, LSHIFT+LCTRL+t to reopen the last closed tab does work, so it appears to not be consistent with the LSHIFT+LCTRL combination.

                        Comment


                        • #14
                          xexets, thank you for the tip! I had tried the right ones separately but, given I may have been frustrated, didn;t try both left and right together. Though I wouldn't want to have to use them forever like this, it is certainly what I would call a temporary patch.

                          Comment


                          • #15
                            It's been two weeks and no update. What's taking so long?

                            The ability to quickly select texts using CTRL + SHIFT + Arrow Key is seriously hurting my day-to-day productivity.

                            When will the firmware update be delivered?

                            Can we just have the older firmware file that actually works, please?

                            Food for thoughts: Maybe you guys should partner with Corsair or something, like how MSI uses SteelSeries keyboard engine. Corsair's keyboard software is much more robust and have more features than you guys'. Saves you the trouble of reinventing the wheels, no?
                            Last edited by ryane; 01-26-2017, 08:55 PM.

                            Comment

                            Working...
                            X