Announcement

Collapse

construction

The AORUS forum is currently under construction.
Please feel free to continue using the forum.
For urgent matters, please contact your nearest service center.
See more
See less

Aorus x5 v6 keyboard not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aorus x5 v6 keyboard not working

    I really do love my x5 v6, however ever since I got it Ive had a few issues with nothing but the keyboard. It's now escalated to the point where the the fusion driver has stopped working all together and I can no longer us the on board keyboard. I'm typing this on a USB and it's just not the same. Before the program stopped working I also had issues like pressing shift and z at the same time in games would also press tab, making dolphin diving in fps practically impossible (I play weird fps games and tab is scoreboard so I'd dolphin dive for a kill then be completely disabled).

    If I could get a driver or version of it thats in between the most recent and the one on the website maybe that would fix it, otherwise I'm completely screwed

  • #2
    Why is this not being addressed? I have the same issue with the keyboard. At first, the backlight stopped functioning simultaneously as the Fusion software. I updated the firmware and updated the software to no avail...
    I can live with the banding in the panel, but something as trivial, not to mention essential as the keyboard not functioning properly , if at all is inexcusable... all the more considering that this us not a $200 chromebook..


    UPDATE: Welp, in an attempt to fix the aforementioned issue with he keyboard, I tried to update the BIOS using the bundled "Drivers Update" utility..
    My laptop is now bricked... Thanks. Really useful software there Gigabyte....
    Last edited by DanielGryphon; 03-09-2017, 07:51 AM.

    Comment


    • #3
      just got my x7 back last week from RMA, same reason for brick as DanielGryphon. It works now but I tried to make a macro in Fusion and now my keyboard is dead...Fusion no longer opens either. *rage!!* can i somehow delete the macro through files or am I SOL? i was just assigning ctrl+shift+esc to the G3 button! the keyboard died as soon as i clicked save. Already tried uninstall/reinstall of fusion. using onscreen keyboard now......seriously with this???

      Comment


      • #4
        Hi scootypuffjr,

        Can you please send me your RMA number and I will take a look on what they did with your unit.

        Thanks.

        Comment


        • #5
          private message sent

          Edit: *disregard, I restarted 3 separate times and the keyboard magically started working again...everything I know about computers is wrong.... On another note, it is interesting to know that I am not the only one whose BIOs update bricked the PC.
          Last edited by scootypuffjr; 03-28-2017, 07:03 AM. Reason: Keyboard works.

          Comment

          Working...
          X